HoloLensでの操作




基礎知識「Near操作」と「Far操作」

 HoloLensではスムーズに操作できるように、ユーザーの操作するオブジェクトとの距離によって、二種類の操作方法が自動で切り替わる仕組みになっています。
具体的にはユーザーの手の届く範囲内にあるオブジェクトやUIは、Near操作と呼ばれる方法で操作し、ユーザーの手の届かない場所にあるオブジェクトやUIはFar操作と呼ばれる方法で操作します。



Near操作

 Near操作では、ボタンを直接指で押したり、オブジェクトを直接指で摘まんだりする事で操作します。
具体的な操作をしている様子に関しては以下のビデオをご覧ください。



Far操作

 Far操作では、手を前方に出した際に手先から表示される線(=ハンドレイ)をオブジェクトに当てた状態で摘まむようにして操作します。また遠くのボタンを押す際も、ハンドレイをボタンに当てた状態で、親指と人差し指を軽く一回タップするようにして操作します。
具体的な操作をしている様子に関しては以下のビデオをご覧ください。



オブジェクトの移動・回転・拡大縮小の操作


移動:Far操作ではハンドレイをオブジェクトに当てて、摘まんだまま動かします。Near操作では直接オブジェクトを手で摘まんで動かします。

回転:Far操作ではオブジェクトを摘まんだまま、手首を捻ることで平面方向に回転ができます。Near操作では直接オブジェクトを手で摘まんだまま、手首を捻ることで自由に回転ができます。また、オブジェクトを選択したときに表示されるバウンディングボックスの辺のハンドルを摘まんで操作することで、一つの軸に制限して回転させることが出来ます。

拡大/縮小:Far操作では両手のハンドレイをオブジェクトに当てて、つまんだまま手を広げたり狭めたりすることで拡大縮小ができます。Near操作ではオブジェクトを両手で摘まんで操作することで拡大縮小ができます。また、バンディングボックスの頂点のハンドルを摘まんで操作することで、片手で拡大縮小ができます。

実際に操作している様子は以下の動画をご覧ください。

WHITEROOMには、会議中に使用できるツールをまとめた「メインメニュー」と、オブジェクトに対するアクションをまとめた「オブジェクトメニュー」に二つのメニューがございます。これらの各機能に関してご紹介します。



基本操作



メニューの呼び出し、移動、ピン止め

 手のひらを自分の方へ向けると簡易的なメニュー(=ハンドメニュー)が表示され、その中からカテゴリー選ぶとメインメニューが表示されます。メニューはいつでも手のひらから呼び出すことができます。

 また、メインメニューの左右のハンドルを掴んで好きな位置に移動することができ、(-)ボタンで閉じる事ができます。そして、ピン止めアイコンを押すことでメニューを自分に追従するモードに切り替えも可能です。



メモリーゲージ、時刻、バッテリー

 メインメニュー上部には左から、メモリーゲージ、時刻、バッテリーゲージが表示されています。
 メモリーゲージは空間上に出しているオブジェクトやマーカー、線の量に応じて使用量が増え、色が青→黄→赤に変化します。ゲージが赤色の状態の際は3Dペンによる描き込みやキャプチャなどの一部の操作が制限されます。



マイク

 メインメニューおよび手のひらを自分の方へ向けた際に表示されるメニュー(=ハンドメニュー)には、マイクのon/offの切り替えボタンが表示されています。(デフォルトでonになっています。)

 ユーザーのマイクのon/offの状態は頭上の表示されているネームプレートおよびOthersのInformation画面からも確認することができます。



ログアウト

 メインメニューおよび手のひらを自分の方へ向けた際に表示されるメニュー(=ハンドメニュー)には、ログアウトボタンが表示されています。

 会議から退出する際や、他の会議に参加される場合はログアウトボタンからご退出ください。

※HoloLensのメニューからアプリケーションを終了していただいても構いません



Assets



Files

 専用サイトにアップロードしたファイルはこの画面に表示されます。ファイルをタップすると空間上にオブジェクトとして表示されます。

 会議に入室後にサイトにファイルを追加・削除・上書きした場合は、Refreshボタンを押すことで、最新の状態に更新されます。

ファイル追加時:filename.extが追加されました。
ファイル削除時:filename.extが削除されました。
変更なしの場合:更新内容はありません。


 空間上に既に出ているファイルのボタンをタップするとそのオブジェクトを選択することができます。



Captures

 現在自分の見ている視界をそのままスクリーンショットする事ができます。撮影した写真は瞬時に空間にオブジェクトとして出現し、参加者全員に共有されます。また、専用サイトの「会議履歴」からも音声メモとともに閲覧可能です。

※メモリゲージが赤色の際は新たなキャプチャを撮影する事はできません。不要なオブジェクトや線を消してください。



Markers

 ○やチェックマークや絵文字などの3Dモデルを空間に出す事ができます。他のオブジェクトと同様に移動・回転でき、Xボタンで削除できます。

 また、絵文字以外のマーカーの色は右のボタンから白・赤・黄・緑に切り替える事ができます。



Tools



3D pen

 指で摘むだけで空間上に自由に線を描くことができます。ペンの種類や太さ、色を変更できるだけでなく、消しゴムで描いた線を消す事もできます。

 また、メモリゲージが赤色の場合は新たに線を描く事はできません。不要なファイルや線を消してください。



Sticky Note

 このように空間上に音声入力で付箋を作成することができます。

付箋を作成する際に、付箋の色、文字の色、付箋のサイズを指定することができ、音声入力は日本語と英語をサポートします。

また、作成した付箋は専用サイトの会議履歴からも閲覧することができます。



Camera

こちらからも新たなキャプチャを撮影することができます。



Pointer

 レーザーポインターのように自分の手の向いている方向に線を出す事ができます。

他のユーザーにもその線は見えており、資料の注目してほしい部分を指し示す際にご利用いただけます。



Slicer

 このように3Dモデルの任意の箇所の断面を見ることができます。

※スライスするための板は会議上に一つだけしか出せないため、譲り合ってご利用下さい。



Teleport

 MR空間内でテレポートする事ができます。自室や書斎などの狭い部屋でWHITEROOMを利用される際にご活用ください。

※二人以上が同時に参加されている拠点ではご利用いただけません。



Broadcast

 このようにPCから参加しているユーザーに対して自分の見ている視界映像を共有する事ができます。

※現時点ではHoloLens2からのみ映像を配信できます。

※PCで配信を視聴する際には別途Monitor For WHITEROOMが必要です。



Browser

 ブラウザ機能を使用すると、Edgeブラウザが表示され、手元で自由にwebサイトを閲覧できます。

※HoloLensでは他のデバイスと異なり、現在見ているページを共有することはできません。ご了承ください。

※Edgeブラウザが起動するまで時間がかかる場合がございます。



Translation

 相手の端末の言語設定が、自分の端末の言語設定と異なる場合、このように相手の話している内容が自動で翻訳され、吹き出しとして表示されます。

現時点で対応している言語は以下の通りです。
・日本語↔英語



Authoring

オーサリング機能を使うことでインタラクティブなXRコンテンツのプロトタイプを簡単に作成することができます。

オーサリング機能の使い方に関しては以下のページをご覧ください。

>オーサリング機能を使いたい


Others



Info

 ユーザーや、会議の情報、ユーザーの一覧を確認することができます。

 WHITEROOMではPCブラウザからも会議に参加することができますが、PCから参加している人はPCマークが表示されます。



Save/Load

 会議の状態(オブジェクトの位置、回転、サイズ、音声メモ、線の書き込みなど)は10分ごとに自動で保存されますが、保存ボタンを押すことで手動でも保存する事ができます。

 会議の状態が保存されているため、いつでも続きから始める事ができます。



Settings


各種設定を変更することができます。




オブジェクトメニュー



基本操作

 空間上に表示されているオブジェクトをタップすることで、そのオブジェクトが選択されて、それと同時にオブジェクトメニューが表示されます。

リモコンの様に手元に表示されるボタンを使い、オブジェクトに対し様々な操作を行うことができます。

 メインメニューと同様に、上部のハンドルを掴むことで好きな位置に移動でき、(-)ボタンでメニューを閉じ、ピン止めボタンで追従モードに切り替え可能です。



Voice Memo

 Voice memoボタンを押すと、音声認識モードになりますので記録したい文章を喋って下さい。喋り終わると自動で文字に起こされるので、チェックボタンを押して確定をするとオブジェクトの上にメモとして表示されます。

 記録した音声メモをShow memo / Hide memoボタンから表示非表示を切り替えることができ、既に音声メモがついているオブジェクトに新たにメモを付けると内容が上書きされます。

 また記録した音声メモは、専用サイトの会議履歴ページから上書き前のものも含めて全て閲覧・保存が可能です。

※現段階では音声入力は日本語と英語をサポートしております。



Control

 動画や3Dモデルのアニメーションを再生したり、複数ページのドキュメントのページをめくる際に使用します。

プレイボタン以外にも、オブジェクト本体をタップすることでも再生・停止や、ページ送りなどの操作が可能です。



Lock

 オブジェクトの移動・回転・スケールの操作をロックする事ができます。一つのオブジェクトを固定して、他のオブジェクトを重ねたり、3Dペンで書き込む際にご活用ください。

画像、動画、オフィスファイル、pdfファイル、キャプチャに関してはロックをすると、移動のみできなくなります。

3Dモデル、点群データ、3Dマップ、音声ファイルに関してはロックすると、移動とタップでの選択ができなくなります。
ロックを解除したい場合はFilesより対象のファイルを選択してください。



Reset

オブジェクトの回転を初期状態に戻します。
※ロック中は使用できません



Gravity

 重力機能をONにすると、オブジェクトに重力がかかったように下に移動します。オブジェクトを床の上にぴったり置きたい際に利用できます。



Shade

 3Dモデルの陰影の表示を切り替えられます。
デフォルトではONになっていますので、既にテクスチャに陰影が焼きこまれている3Dモデルを使用される際や、フォトグラメトリにより作成した3Dモデルを表示する際には、陰影をoffにしてください。



Scale

 3Dモデルを原寸大やその1/2倍、2倍などのスケールに切り替えることが出来ます。
CADモデルなど実際と同じスケールで見たい場合などにご利用くだしさい。また、Reset ScaleでオブジェクトをFilesから出した状態のスケールに戻すことができます。



Remove

 Removeボタンを押すと対象のオブジェクトが空間から削除されます。削除したオブジェクトはメインメニューのFiles画面から再び表示させることができます。